Back to overview
Downtime

New site returned nothing

Mar 24, 2024 at 04:15pm UTC
Affected services
Main Website

Resolved
Mar 24, 2024 at 04:21pm UTC

The sites back online

Created
Mar 24, 2024 at 04:15pm UTC

The new site as returned nothing.