Back to overview
Downtime

All of the Splamei Network down in a major server outage

Oct 30 at 01:07am GMT
Affected services
New Website
Splamei Network (Global)
1.1 - SplameiPlay
1.1 - Bitorpito Deluxe
1.1 - Dotafib
1.1 - Rhythm Plus - Splamei Client

Resolved
Oct 30 at 02:23am GMT

The 'SplameiPlay' and 'Bitorpito Deluxe updater' servers are back online. We are still working on preventing this issue in the future. Thank you for understanding and patience.

Updated
Oct 30 at 02:22am GMT

The 'Dotafib updater' server is now online and working. Thank you for your understanding during these times.

Updated
Oct 30 at 02:18am GMT

The global 'Splamei Network Status' and 'Rhythm Plus - Splamei Client updater' servers are now back online. We still are working on figuring out what caused this outage.

Updated
Oct 30 at 02:18am GMT

The main website has now recovered and is back online. Thank you for your understanding.

Updated
Oct 30 at 01:10am GMT

The Main website has also gone down during this outage. This means the entire Splamei Network has been affected by this outage. We are really sorry for the inconvenience this is causing.

Updated
Oct 30 at 01:09am GMT

The 'SplameiPlay updater' and 'Bitorpito Deluxe updater' have now gone down again, for the same reason of timing out. We apologise for anyone affected by this outage.

Updated
Oct 30 at 01:08am GMT

The 'Dotafib updater' server has now also gone down for the same reason. We are still working on fixing this issue.

Created
Oct 30 at 01:07am GMT

The global 'Splamei Network Status' and 'Rhythm Plus - Splamei Client updater' servers have gone down due to not responding quick enough to requests. We are currently working on resolving this issue.