Service wide downtime
Resolved
Mar 18, 2026 at 09:25pm UTC
Main Website has recovered. We apologise for any inconvenience this downtime may have caused.
Affected services
Updated
Mar 18, 2026 at 09:24pm UTC
Docs Website is bow back online.
Affected services
Updated
Mar 18, 2026 at 09:13pm UTC
SplameiPlay Flow 1.2 recovered.
Affected services
Updated
Mar 18, 2026 at 09:13pm UTC
Splamei Network (Global) and 1.1 - Rhythm Plus - Splamei Client are both back online.
Affected services
Updated
Mar 18, 2026 at 09:12pm UTC
SplameiPlay Updater (SplameiPlay Flow 1.2) has recovered.
Affected services
Updated
Mar 18, 2026 at 09:12pm UTC
1.1 - Bitorpito Deluxe is also back online. We're still working to fix the root cause.
Affected services
Updated
Mar 18, 2026 at 09:12pm UTC
1.1 - SplameiPlay is back online.
Affected services
Updated
Mar 18, 2026 at 09:11pm UTC
Docs Website and SplameiPlay Updater (SplameiPlay Flow 1.2) has now gone down however 1.1 - Dotafib is back online
Affected services
Updated
Mar 18, 2026 at 09:10pm UTC
Main Website has gone down again.
Affected services
Updated
Mar 18, 2026 at 09:09pm UTC
1.1 - Dotafib has now also gone down
Affected services
Updated
Mar 18, 2026 at 09:09pm UTC
1.1 - SplameiPlay and 1.1 - Bitorpito Deluxe have both gone down.
Affected services
Updated
Mar 18, 2026 at 09:08pm UTC
SplameiPlay Flow 1.2 has joined the party! Seriously though, we're still working on finding the root cause.
Affected services
Updated
Mar 18, 2026 at 09:07pm UTC
Splamei Network (Global) has now also gone down
Affected services
Updated
Mar 18, 2026 at 09:07pm UTC
The Rhythm Plus - Splamei Client has now gone down. We're trying to find the source of the issue.
Affected services
Updated
Mar 18, 2026 at 04:34am UTC
The main website is now back online. Thank you for your understanding.
Affected services
Created
Mar 18, 2026 at 04:31am UTC
The main website has gone down for an unknown reason. We're working hard to fix the downtime.
Affected services